Business Automation for Successful ITsTrusted Since 2003

CommitCRM System Requirements

Recommended Requirements

Hardware
Intel® Pentium® IV
4 GB RAM or up
1 GB free disk space
100 Mbps Fast Ethernet LAN

Software
Microsoft® Windows 8.1, Windows 8, Windows 7, Windows Vista
Microsoft® Word® 2003 or later
Microsoft® Outlook® 2003 or later

CommitCRM Web Interface Requirements

Hardware
Internet connection to the server with a static IP address/domain name
Approximately 50mb available disk space on server hard drive
Recommended screen display resolution of 1024 * 768 (256+ colors)

Software
CommitCRM Web Interface runs as a Windows service (on the same server where CommitCRM is installed)

Microsoft® Windows® 2003/2008/2012/2012R2 or
Small Business Server (SBS) 2003/Small Business Server (SBS) 2008/ Windows Server 2012/2012R2 or
Windows 8.1 /Windows 8 /Windows 7 / Vista Business that acts as a server/main computer.

CommitCRM software 5.0+
Microsoft® Internet Explorer Browser (8.0+) with JavaScript enabled.
Mozilla Firefox (4.0 or up) with JavaScript enabled.
Google Chrome (14.0 or up) with JavaScript enabled.
Safari (6.2 or up) with JavaScript enabled.

CommitCRM-QuickBooks Link

Software

The following editions of QuickBooks Online are supported:
   – Australia, Canada, United Kingdom, United States (requires CommitCRM 9 or above)

The following US versions of QuickBooks Desktop are supported:
   – QuickBooks Pro 2016                   (requires CommitCRM 9 or above)
   – QuickBooks Premier 2016            (requires CommitCRM 9 or above)
   – QuickBooks Enterprise 2016         (requires CommitCRM 9 or above)
   – QuickBooks Pro 2015                   (requires CommitCRM 9 or above)
   – QuickBooks Premier 2015            (requires CommitCRM 9 or above)
   – QuickBooks Enterprise 2015         (requires CommitCRM 9 or above)
   – QuickBooks Pro 2014                   (requires CommitCRM 7.0 or above)
   – QuickBooks Premier 2014            (requires CommitCRM 7.0 or above)
   – QuickBooks Enterprise 2014         (requires CommitCRM 7.0 or above)
   – QuickBooks Pro 2013                   (requires CommitCRM 5.5 or above)
   – QuickBooks Premier 2013            (requires CommitCRM 5.5 or above)
   – QuickBooks Enterprise 2013         (requires CommitCRM 5.5 or above)
   – QuickBooks Pro 2012                   (requires CommitCRM 5.5 or above)
   – QuickBooks Premier 2012            (requires CommitCRM 5.5 or above)
   – QuickBooks Enterprise 2012         (requires CommitCRM 5.5 or above)
   – QuickBooks Pro 2011                   (requires CommitCRM 5.5 or above)
   – QuickBooks Premier 2011           (requires CommitCRM 5.5 or above)
   – QuickBooks Enterprise 2011        (requires CommitCRM 5.5 or above)
   – QuickBooks Pro 2010
   – QuickBooks Premier 2010
   – QuickBooks Enterprise 2010
   – QuickBooks Pro 2009
   – QuickBooks Premier 2009
   – QuickBooks Enterprise 2009
   – QuickBooks Pro 2008
   – QuickBooks Premier 2008
   – QuickBooks Enterprise 2008
  
Note for QuickBooks 2009, or above, users:
CommitCRM 4.5, or above, is required to integrate with QuickBooks 2009.
CommitCRM-QuickBooks Link uses a single currency. Multi-currency is not supported.

The following Canadian versions of QuickBooks Desktop are supported:
   – QuickBooks Canada Pro 2016                   (requires CommitCRM 9 or above)
   – QuickBooks Canada Premier 2016            (requires CommitCRM 9 or above)
   – QuickBooks Canada Pro 2015                   (requires CommitCRM 9 or above)
   – QuickBooks Canada Premier 2015            (requires CommitCRM 9 or above)
   – QuickBooks Canada Pro 2014                  (requires CommitCRM 7.0 or above)
   – QuickBooks Canada Premier 2014            (requires CommitCRM 7.0 or above)
   – QuickBooks Canada Pro 2013
   – QuickBooks Canada Premier 2013
   – QuickBooks Canada Pro 2012
   – QuickBooks Canada Premier 2012
   – QuickBooks Canada Pro 2011
   – QuickBooks Canada Premier 2011
   – QuickBooks Canada Pro 2010
   – QuickBooks Canada Premier 2010
   – QuickBooks Canada Pro 2009
   – QuickBooks Canada Premier 2009
   – QuickBooks Canada Pro 2008
   – QuickBooks Canada Premier 2008

The following UK versions of QuickBooks Desktop are supported:
   – QuickBooks UK Pro 2016                   (requires CommitCRM 9 or above)
   – QuickBooks UK Premier 2016            (requires CommitCRM 9 or above)
   – QuickBooks UK Pro 2015                   (requires CommitCRM 9 or above)
   – QuickBooks UK Premier 2015            (requires CommitCRM 9 or above)
   – QuickBooks UK Pro 2014                  (requires CommitCRM 7.0 or above)
   – QuickBooks UK Premier 2014            (requires CommitCRM 7.0 or above)
   – QuickBooks UK Pro 2013
   – QuickBooks UK Premier 2013
   – QuickBooks UK Pro 2012
   – QuickBooks UK Premier 2012
   – QuickBooks UK Pro 2011
   – QuickBooks UK Premier 2011
   – QuickBooks UK Pro 2010
   – QuickBooks UK Premier 2010
   – QuickBooks UK Pro 2008

The following Australian versions of QuickBooks are supported*:
   – Reckon Accounts (formerly QuickBooks Australia) Pro, Premier, Enterprise 2014-2016
   – QuickBooks Australia Pro 2013
   – QuickBooks Australia Premier 2013
   – QuickBooks Australia Pro 2012
   – QuickBooks Australia Premier 2012
   – QuickBooks Australia Pro 2010/11
   – QuickBooks Australia Premier 2010/11
   – QuickBooks Australia Pro 2009/10
   – QuickBooks Australia Premier 2009/10
   – QuickBooks Australia Pro 2008/9
   – QuickBooks Australia Premier 2008/9

* The integration with QuickBooks Australia was tested and works in US compatibility mode

[multi user mode is supported]

QBFC 7.0 / 5.0 – QuickBooks platform for integration, developed by Intuit. Click here to download QBFC from CommitCRM’s web site.

CommitCRM-Outlook Sync

Software
The following versions of Outlook® are supported:
– Microsoft® Outlook® 2000
– Microsoft® Outlook® 2003
– Microsoft® Outlook® 2007
– Microsoft® Outlook® 2010
– Microsoft® Outlook® 2013

You may use the CommitCRM-Outlook Sync with the following versions of Microsoft® Exchange Server:
– Microsoft® Exchange Server 2000
– Microsoft® Exchange Server 2003
– Microsoft® Exchange Server 2007
– Microsoft® Exchange Server 2010

Note: Using an Exchange Server with the CommitCRM-Outlook Sync is optional.

CommitCRM Alerts Server

– CommitCRM software 4.3 or later
– CommitCRM Alerts Server module
– Windows 2003/SBS 2003/2008/SBS 2008/ 2012/2012R2 /7 Pro or above/Vista Business/XP Pro
– Connection to an SMTP mail server

CommitCRM Email Connector

– CommitCRM software 4.3 or later
– CommitCRM Email Connector module
– Windows 2003/SBS 2003/2008/SBS 2008/ 2012/2012R2 /7 Pro or above/Vista Business/XP Pro
– Connection to a mail server
– POP3 mail server (including Exchange® servers with POP3 enabled)
– SMTP mail server to send responses and forward unrecognized emails

MS-Word®, MS-Outlook® and MS-Windows® are registered trademarks of Microsoft Corporation in the United States and other countries.
Symantec™ WinFax™ is a registered trademark of Symantec Corporation in the United States and other countries.
Intel® Pentium® is a registered trademark of Intel Corporation in the United States and other countries.