Import and Export FAQ

From CommitCRM-Wiki
Jump to: navigation, search
FAQ > Import and Export FAQ

Getting Started

Advanced Use



Can I import my customers into CommitCRM?

You can import Accounts into CommitCRM together with phone numbers, addresses etc. To do so, go to the Accounts windows > Import & Export> Import Accounts, and select the type of file to be imported (MS Excel, Text, MS Outlook, MS Outlook Express, Database, Paradox). Your accounts will now be imported.

Note: You can also import customers/vendors from QuickBooks using the QuickBooks menu in the Account window > Import new Records/Update Linked Records from QuickBooks.

Can I import tickets from my old system into CommitCRM?

Yes. You can import tickets from various sources into CommitCRM.

To import, go to the Tickets window > Import & Export> Import Tickets.

Can I import my item list into CommitCRM?

You can import items (product/parts, labor items and expense items) into CommitCRM. To do so, go to the Item window > Import & Export> Import Items.

Note: You can also import an item list from QuickBooks using the QuickBooks menu in the Items window > Import new Records/Update Linked Records from QuickBooks.

Can I import assets into CommitCRM?

Yes. You can import assets from various sources into CommitCRM.

When importing, you should select the type of assets you want to import: Hardware, Software or Other. You can also select whether to link all imported assets to a selected account or import them without assigning an account to them.

To import, go to the Assets window > Import & Export> Import Assets.

You can also import assets from the Assets tab in the Accounts window by right-clicking and selecting Import Assets... In this case all the imported assets will be linked to the selected Account.


Can I export data from CommitCRM?

You can export data displayed in CommitCRM's tables/grids to Word®, Excel®, HTML, and more by clicking on the ‘Export’ button on the toolbar, or by right-clicking above the table/grid, selecting Table Options > Export Table Data and then selecting the desired format.

You can also use the Advanced Data Export Wizard in order to export selected fields from CommitCRM to Word®, Excel®, HTML, and more. This way you can control the exact data that is exported and the order of the fields in the output file.

The Advanced Data Export Wizard can be activated from the Tools > Import & Export > Export... option or from the relevant Window (Accounts, Tickets, etc.) by clicking on Account > Import & Exports > Advanced Data Export.

The Data Export Wizard window opens and you can now select to perform the following actions:

  • choose which fields to export and in what order should they be exported to the file
  • define a filter on the data to be exported, including advanced filtering options
  • define sort criteria for the output

Select the output format and the output file name to save to.


Can I export only selected fields from CommitCRM (Advanced Data Export)?

You can use the Advanced Data Export Wizard in order to export selected fields from CommitCRM to Word®, Excel®, HTML, and more. This way you can control the exact data that is exported and the order of the fields in the output file.

The Advanced Data Export Wizard can be activated from the Tools > Import & Export > Export... option or from the relevant Window (Accounts, Tickets, etc.) by clicking on Account > Import & Exports > Advanced Data Export.

The Data Export Wizard window opens and you can now select to perform the following actions:

  • choose which fields to export and in what order should they be exported to the file
  • define a filter on the data to be exported, including advanced filtering options
  • define sort criteria for the output

Select the output format and the output file name to save to.


What is the difference between syncing with Outlook and importing from Outlook?

CommitCRM allows you to import your Outlook contacts into CommitCRM. When importing, every Outlook contact creates a CommitCRM Account record. Importing records is a one-way data transfer process from Outlook into CommitCRM.

The CommitCRM-Outlook Sync module supports two-way data synchronization. Additions and changes performed in one program are transferred to the other.

Another difference between importing and synchronizing Outlook and CommitCRM data is that with the import feature, you can only import Outlook Contacts. The synchronization module allows information from Contacts, Appointments and Tasks to be transferred.


Can I batch delete all Account records I imported by mistake?

Yes. In the Accounts window go to the Accounts menu > Import & Export > Delete Imported Records. From the list of imported batches, select the imported batch you want to delete and click on the ‘Delete Imported Records’ button. All the records with the selected batch will be deleted, except records that have been linked to similar records, like: tickets, appointments, documents, etc.

Note though that since syncing is a much more complex two way process, unlike a standard import, there is currently no batch delete option available for data imported via an Outlook or Quickbooks sync.

See Also